openSUSE 10 Security Update : xine-devel (xine-devel-5204)

High Nessus Plugin ID 32392


The remote openSUSE host is missing a security update.


Specially crafted NSF files could potentially be exploited to execute arbitrary code (CVE-2008-1878).

Specially crafted files or streams could potentially be abused to trick applications that support speex into executing arbitrary code (CVE-2008-1686).


Update the affected xine-devel packages.

Plugin Details

Severity: High

ID: 32392

File Name: suse_xine-devel-5204.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2008/05/20

Modified: 2016/12/22

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:xine-devel, p-cpe:/a:novell:opensuse:xine-extra, p-cpe:/a:novell:opensuse:xine-lib, p-cpe:/a:novell:opensuse:xine-lib-32bit, p-cpe:/a:novell:opensuse:xine-ui, p-cpe:/a:novell:opensuse:xine-ui-32bit, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/04/21

Reference Information

CVE: CVE-2008-1686, CVE-2008-1878

CWE: 119, 189