openSUSE 10 Security Update : MozillaFirefox (MozillaFirefox-5219)

High Nessus Plugin ID 32114


The remote openSUSE host is missing a security update.


This update brings Mozilla Firefox to security update version

Following security problems were fixed :

- MFSA 2008-20/CVE-2008-1380: Fixes for security problems in the JavaScript engine described in MFSA 2008-15 (CVE-2008-1237) introduced a stability problem, where some users experienced frequent crashes during JavaScript garbage collection. These crashes may be exploitable if someone finds a reliable way to trigger the crash.


Update the affected MozillaFirefox packages.

Plugin Details

Severity: High

ID: 32114

File Name: suse_MozillaFirefox-5219.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2008/05/01

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:MozillaFirefox, p-cpe:/a:novell:opensuse:MozillaFirefox-translations, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/04/27

Reference Information

CVE: CVE-2008-1237, CVE-2008-1380

CWE: 399