openSUSE 10 Security Update : audit (audit-5212)

Medium Nessus Plugin ID 32076


The remote openSUSE host is missing a security update.


A bug in the audit_log_user_command() function could lead to a buffer overflow. No program in openSUSE uses that function. Third-party applications could be affected though (CVE-2008-1628).


Update the affected audit packages.

Plugin Details

Severity: Medium

ID: 32076

File Name: suse_audit-5212.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2008/04/28

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.1

Vector: CVSS2#AV:L/AC:M/Au:S/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:audit, p-cpe:/a:novell:opensuse:audit-devel, p-cpe:/a:novell:opensuse:audit-libs, p-cpe:/a:novell:opensuse:audit-libs-32bit, p-cpe:/a:novell:opensuse:audit-libs-python, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/04/24

Reference Information

CVE: CVE-2008-1628

CWE: 119, 264