openSUSE 10 Security Update : libpng (libpng-5180)

High Nessus Plugin ID 32024


The remote openSUSE host is missing a security update.


Specially crafted png files could overwrite arbitrary memory.
Attackers could potentially exploit that to execute arbitrary code (CVE-2008-1382).


Update the affected libpng packages.

Plugin Details

Severity: High

ID: 32024

File Name: suse_libpng-5180.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2008/04/22

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libpng, p-cpe:/a:novell:opensuse:libpng-32bit, p-cpe:/a:novell:opensuse:libpng-devel, p-cpe:/a:novell:opensuse:libpng-devel-32bit, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/04/15

Reference Information

CVE: CVE-2008-1382

CWE: 189