openSUSE 10 Security Update : flash-player (flash-player-5161)

High Nessus Plugin ID 31965


The remote openSUSE host is missing a security update.


This flash player update to version fixes several security problems. In the worst case an attacker could potentially have flash-player execute arbitrary code via specially crafted files.
(CVE-2007-5275, CVE-2007-6243, CVE-2007-6637, CVE-2007-6019, CVE-2007-0071, CVE-2008-1655, CVE-2008-1654)


Update the affected flash-player package.

Plugin Details

Severity: High

ID: 31965

File Name: suse_flash-player-5161.nasl

Version: $Revision: 1.16 $

Type: local

Agent: unix

Published: 2008/04/17

Modified: 2016/12/22

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:flash-player, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/04/09

Exploitable With


Core Impact

Reference Information

CVE: CVE-2007-0071, CVE-2007-5275, CVE-2007-6019, CVE-2007-6243, CVE-2007-6637, CVE-2008-1654, CVE-2008-1655

CWE: 20, 79, 189, 352