openSUSE 10 Security Update : tk (tk-4973)

Medium Nessus Plugin ID 31846


The remote openSUSE host is missing a security update.


Specially crafted GIF images could cause a buffer overflow and crash tk. It seems unlikely but not entirely impossible that this overflow can be exploited to execute arbitrary code (CVE-2008-0553).


Update the affected tk packages.

Plugin Details

Severity: Medium

ID: 31846

File Name: suse_tk-4973.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2008/04/11

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:tk, p-cpe:/a:novell:opensuse:tk-32bit, p-cpe:/a:novell:opensuse:tk-devel, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/02/06

Reference Information

CVE: CVE-2008-0553

CWE: 119