FreeBSD : opera -- multiple vulnerabilities (ad4a00fa-0157-11dd-8bd3-001372ae3ab9)

High Nessus Plugin ID 31831


The remote FreeBSD host is missing one or more security-related updates.


Opera Software reports of multiple security issues in Opera. All of them can lead to arbitrary code execution. Details are as the following :

- Newsfeed prompt can cause Opera to execute arbitrary code

- Resized canvas patterns can cause Opera to execute arbitrary code


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 31831

File Name: freebsd_pkg_ad4a00fa015711dd8bd3001372ae3ab9.nasl

Version: $Revision: 1.16 $

Type: local

Published: 2008/04/11

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:linux-opera, p-cpe:/a:freebsd:freebsd:opera, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/04/05

Vulnerability Publication Date: 2008/04/03

Reference Information

CVE: CVE-2008-1761, CVE-2008-1762

BID: 28585

CWE: 399