openSUSE 10 Security Update : xine-devel (xine-devel-5137)

Medium Nessus Plugin ID 31781


The remote openSUSE host is missing a security update.


Specially crafted files could cause integer overflows in the xine library. Attackers could potentially exploit that to execute arbitrary code with the privileges of the user who opened such a file (CVE-2008-1482).


Update the affected xine-devel packages.

Plugin Details

Severity: Medium

ID: 31781

File Name: suse_xine-devel-5137.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2008/04/04

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:xine-devel, p-cpe:/a:novell:opensuse:xine-extra, p-cpe:/a:novell:opensuse:xine-lib, p-cpe:/a:novell:opensuse:xine-lib-32bit, p-cpe:/a:novell:opensuse:xine-ui, p-cpe:/a:novell:opensuse:xine-ui-32bit, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/03/27

Reference Information

CVE: CVE-2008-1482

CWE: 119, 189