openSUSE 10 Security Update : silc-toolkit (silc-toolkit-5143)

High Nessus Plugin ID 31777


The remote openSUSE host is missing a security update.


A flaw in processing PKCS#1-Messages could lead to a buffer overflow.
Remote attackers could exploit that to crash the server.


Update the affected silc-toolkit packages.

Plugin Details

Severity: High

ID: 31777

File Name: suse_silc-toolkit-5143.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2008/04/04

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:silc-toolkit, p-cpe:/a:novell:opensuse:silc-toolkit-devel, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/03/31