openSUSE 10 Security Update : xine-devel (xine-devel-5078)

High Nessus Plugin ID 31459


The remote openSUSE host is missing a security update.


This update of xine fixes a possible buffer overflow that can be triggered via FLAC tags to execute arbitrary code (CVE-2008-0486) and a possible buffer overflow in the matroska demuxer.


Update the affected xine-devel packages.

Plugin Details

Severity: High

ID: 31459

File Name: suse_xine-devel-5078.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2008/03/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:xine-devel, p-cpe:/a:novell:opensuse:xine-extra, p-cpe:/a:novell:opensuse:xine-lib, p-cpe:/a:novell:opensuse:xine-lib-32bit, p-cpe:/a:novell:opensuse:xine-ui, p-cpe:/a:novell:opensuse:xine-ui-32bit, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/03/07

Reference Information

CVE: CVE-2008-0486

CWE: 189