openSUSE 10 Security Update : compat-openssl097g (compat-openssl097g-5054)

Medium Nessus Plugin ID 31391


The remote openSUSE host is missing a security update.


This update of openssl fixes a off-by-one buffer overflow in function SSL_get_shared_ciphers(). This vulnerability potentially allows remote code execution; depending on memory layout of the process.

We released updates for openssl already, but an update for the compat 0.9.7g openssl libraries was missing and is provided with this patch.


Update the affected compat-openssl097g packages.

Plugin Details

Severity: Medium

ID: 31391

File Name: suse_compat-openssl097g-5054.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2008/03/07

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:compat-openssl097g, p-cpe:/a:novell:opensuse:compat-openssl097g-32bit, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/02/28

Reference Information

CVE: CVE-2007-5135

CWE: 189