openSUSE 10 Security Update : apache2-mod_jk (apache2-mod_jk-4992)

Medium Nessus Plugin ID 31319


The remote openSUSE host is missing a security update.


Fixed various issues in tomcat :

- CVE-2006-7196: Cross-site scripting (XSS) vulnerability in example JSP applications

- CVE-2007-3382: Handling of cookies containing a ' character

- CVE-2007-3385: Handling of \' in cookies

- CVE-2007-5641: tomcat path traversal / information leak

- CVE-2007-1860: directory traversal

- CVE-2008-0128: tomcat https information disclosure

- CVE-2005-2090: tomcat HTTP Request Smuggling


Update the affected apache2-mod_jk packages.

Plugin Details

Severity: Medium

ID: 31319

File Name: suse_apache2-mod_jk-4992.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2008/02/29

Modified: 2016/12/22

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:apache2-mod_jk, p-cpe:/a:novell:opensuse:mod_jk-ap20, p-cpe:/a:novell:opensuse:tomcat5, p-cpe:/a:novell:opensuse:tomcat5-admin-webapps, p-cpe:/a:novell:opensuse:tomcat5-webapps, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/02/11

Exploitable With


Reference Information

CVE: CVE-2005-2090, CVE-2006-7196, CVE-2007-1860, CVE-2007-3382, CVE-2007-3385, CVE-2007-5641, CVE-2008-0128

CWE: 16, 20, 22, 79, 94, 200