openSUSE 10 Security Update : opera (opera-5028)

High Nessus Plugin ID 31309


The remote openSUSE host is missing a security update.


This is a version update for Opera to version 9.26 to fix :

- Fixed an issue where simulated text inputs could trick users into uploading arbitrary files, as reported by Mozilla.

- Image properties can no longer be used to execute scripts, as reported by Max Leonov.

- Fixed an issue where the representation of DOM attribute values could allow cross site scripting, as reported by


Update the affected opera package.

Plugin Details

Severity: High

ID: 31309

File Name: suse_opera-5028.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2008/02/28

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:opera, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/02/21