FreeBSD : mozilla -- multiple vulnerabilities (810a5197-e0d9-11dc-891a-02061b08fc24)

High Nessus Plugin ID 31155


The remote FreeBSD host is missing one or more security-related updates.


The Mozilla Foundation reports of multiple security issues in Firefox, SeaMonkey, and Thunderbird. Several of these issues can probably be used to run arbitrary code with the privilege of the user running the program.

- Web forgery overwrite with div overlay

- URL token stealing via stylesheet redirect

- Mishandling of locally-saved plain text files

- File action dialog tampering

- Possible information disclosure in BMP decoder

- Web browsing history and forward navigation stealing

- Directory traversal via chrome: URI

- Stored password corruption

- Privilege escalation, XSS, Remote Code Execution

- Multiple file input focus stealing vulnerabilities

- Crashes with evidence of memory corruption (rv:


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 31155

File Name: freebsd_pkg_810a5197e0d911dc891a02061b08fc24.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2008/02/25

Modified: 2016/12/08

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:firefox, p-cpe:/a:freebsd:freebsd:flock, p-cpe:/a:freebsd:freebsd:linux-firefox, p-cpe:/a:freebsd:freebsd:linux-firefox-devel, p-cpe:/a:freebsd:freebsd:linux-flock, p-cpe:/a:freebsd:freebsd:linux-seamonkey, p-cpe:/a:freebsd:freebsd:linux-seamonkey-devel, p-cpe:/a:freebsd:freebsd:seamonkey, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2008/02/22

Vulnerability Publication Date: 2008/02/07

Reference Information

CVE: CVE-2008-0412, CVE-2008-0413, CVE-2008-0414, CVE-2008-0415, CVE-2008-0417, CVE-2008-0418, CVE-2008-0419, CVE-2008-0420, CVE-2008-0591, CVE-2008-0592, CVE-2008-0593, CVE-2008-0594

CWE: 20, 22, 79, 94, 200, 399