openSUSE 10 Security Update : xdg-utils (xdg-utils-4983)

Medium Nessus Plugin ID 31115


The remote openSUSE host is missing a security update.


xdg-open and xdg-email didn't properly check their arguments.
Therefore e.g. URLs passed to those programs could contain shell code that got executed (CVE-2008-0386).


Update the affected xdg-utils package.

Plugin Details

Severity: Medium

ID: 31115

File Name: suse_xdg-utils-4983.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2008/02/18

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:xdg-utils, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2008/02/11

Reference Information

CVE: CVE-2008-0386

CWE: 20