openSUSE 10 Security Update : pcre (pcre-4980)

High Nessus Plugin ID 31091


The remote openSUSE host is missing a security update.


Specially crafted regular expressions could lead to a buffer overflow in the pcre library. Applications using pcre to process regular expressions from untrusted sources could therefore potentially be exploited by attackers to execute arbitrary code.


Update the affected pcre packages.

Plugin Details

Severity: High

ID: 31091

File Name: suse_pcre-4980.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2008/02/14

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:pcre, p-cpe:/a:novell:opensuse:pcre-32bit, p-cpe:/a:novell:opensuse:pcre-devel, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/02/07