openSUSE 10 Security Update : postgresql (postgresql-4958)

Medium Nessus Plugin ID 30198


The remote openSUSE host is missing a security update.


This version update to 8.1.11 fixes among other things several security issues :

- Index Functions Privilege Escalation: CVE-2007-6600

- Regular Expression Denial-of-Service: CVE-2007-4772, CVE-2007-6067, CVE-2007-4769

- DBLink Privilege Escalation: CVE-2007-6601


Update the affected postgresql packages.

Plugin Details

Severity: Medium

ID: 30198

File Name: suse_postgresql-4958.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2008/02/06

Modified: 2016/12/22

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:postgresql, p-cpe:/a:novell:opensuse:postgresql-contrib, p-cpe:/a:novell:opensuse:postgresql-devel, p-cpe:/a:novell:opensuse:postgresql-libs, p-cpe:/a:novell:opensuse:postgresql-libs-32bit, p-cpe:/a:novell:opensuse:postgresql-pl, p-cpe:/a:novell:opensuse:postgresql-server, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/01/31

Reference Information

CVE: CVE-2007-4769, CVE-2007-4772, CVE-2007-6067, CVE-2007-6600

CWE: 189, 264, 399