openSUSE 10 Security Update : geronimo (geronimo-4957)

High Nessus Plugin ID 30193


The remote openSUSE host is missing a security update.


A chown in the geronimo init script could change ownership of directories it did not own, due to following symlinks. The default setup would corrupt /var/tmp on start.


Update the affected geronimo packages.

Plugin Details

Severity: High

ID: 30193

File Name: suse_geronimo-4957.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2008/02/06

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:geronimo, p-cpe:/a:novell:opensuse:geronimo-jetty-servlet-container, p-cpe:/a:novell:opensuse:geronimo-tomcat-servlet-container, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2008/01/29