FreeBSD : libxine -- buffer overflow vulnerability (6ecd0b42-ce77-11dc-89b1-000e35248ad7)

High Nessus Plugin ID 30127


The remote FreeBSD host is missing a security-related update.


xine project reports :

A new xine-lib version is now available. This release contains a security fix (remotely-exploitable buffer overflow, CVE-2006-1664).
(This is not the first time that that bug has been fixed...) It also fixes a few more recent bugs, such as the audio output problems in 1.1.9.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 30127

File Name: freebsd_pkg_6ecd0b42ce7711dc89b1000e35248ad7.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2008/01/30

Modified: 2014/04/15

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:libxine, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2008/01/29

Vulnerability Publication Date: 2008/01/23

Reference Information

CVE: CVE-2006-1664

Secunia: 19853