FreeBSD : libxine -- buffer overflow vulnerability (02eedd3c-c6b5-11dc-93b6-000e35248ad7)

Medium Nessus Plugin ID 30029


The remote FreeBSD host is missing a security-related update.


xine project reports :

A new xine-lib version is now available. This release contains a security fix (remotely-exploitable buffer overflow, CVE-2008-0225). It also contains a read-past-end fix for an internal library function which is only used if the OS does not supply it and a rendering fix for Darwin/PPC.


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 30029

File Name: freebsd_pkg_02eedd3cc6b511dc93b6000e35248ad7.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2008/01/21

Modified: 2014/04/15

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:libxine, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2008/01/19

Vulnerability Publication Date: 2008/01/08

Reference Information

CVE: CVE-2008-0225

Secunia: 28384

CWE: 119