openSUSE 10 Security Update : libexif5 (libexif5-4882)

Medium Nessus Plugin ID 29959


The remote openSUSE host is missing a security update.


One bug in libexif5 was identified by a Google Security Audit done by Meder Kydyraliev.

CVE-2007-6352: Integer overflows in the thumbnail handler could be used to overflow buffers and potentially execute code or crash a program using libexif.


Update the affected libexif5 package.

Plugin Details

Severity: Medium

ID: 29959

File Name: suse_libexif5-4882.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2008/01/14

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libexif5, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/01/09

Reference Information

CVE: CVE-2007-6352

CWE: 189