openSUSE 10 Security Update : te_ams (te_ams-4819)

Medium Nessus Plugin ID 29890

Synopsis

The remote openSUSE host is missing a security update.

Description

Buffer overflows in dvips and dviljk could be triggered by specially crafted dvi files (CVE-2007-5935, CVE-2007-5937). dvips additionally created temporary files in an insecure manner (CVE-2007-5936).

Solution

Update the affected te_ams packages.

Plugin Details

Severity: Medium

ID: 29890

File Name: suse_te_ams-4819.nasl

Version: 1.12

Type: local

Agent: unix

Published: 2008/01/08

Updated: 2019/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:te_ams, p-cpe:/a:novell:opensuse:te_cont, p-cpe:/a:novell:opensuse:te_dvilj, p-cpe:/a:novell:opensuse:te_eplai, p-cpe:/a:novell:opensuse:te_kpath, p-cpe:/a:novell:opensuse:te_latex, p-cpe:/a:novell:opensuse:te_mpost, p-cpe:/a:novell:opensuse:te_nfs, p-cpe:/a:novell:opensuse:te_omega, p-cpe:/a:novell:opensuse:te_ptex, p-cpe:/a:novell:opensuse:te_web, p-cpe:/a:novell:opensuse:tetex, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/12/11

Reference Information

CVE: CVE-2007-5935, CVE-2007-5936, CVE-2007-5937

CWE: 119, 264