openSUSE 10 Security Update : libsndfile (libsndfile-4430)

High Nessus Plugin ID 29881


The remote openSUSE host is missing a security update.


This update fixes a possible buffer overflow that occurs while reading decoded PCM data from the FLAC library. (CVE-2007-4974)


Update the affected libsndfile packages.

Plugin Details

Severity: High

ID: 29881

File Name: suse_libsndfile-4430.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2008/01/08

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libsndfile, p-cpe:/a:novell:opensuse:libsndfile-32bit, p-cpe:/a:novell:opensuse:libsndfile-devel, p-cpe:/a:novell:opensuse:libsndfile-octave, p-cpe:/a:novell:opensuse:libsndfile-progs, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/09/25

Reference Information

CVE: CVE-2007-4974

CWE: 119