openSUSE 10 Security Update : apache2-mod_python (apache2-mod_python-4448)

Medium Nessus Plugin ID 29879


The remote openSUSE host is missing a security update.


This update fixes a buffer overflow in apache2-mod_python that occurs while using python-based output-filter. This bug can be triggered remotely to read possibly confidential data from the process space of the web-server and in rare cases to execute arbitrary code.


Update the affected apache2-mod_python package.

Plugin Details

Severity: Medium

ID: 29879

File Name: suse_apache2-mod_python-4448.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2008/01/08

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:apache2-mod_python, cpe:/o:novell:opensuse:10.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/09/26

Reference Information

CVE: CVE-2004-2680