openSUSE 10 Security Update : flash-player (flash-player-4855)

High Nessus Plugin ID 29784


The remote openSUSE host is missing a security update.


This flash player update to version fixes several security problems. In the worst case an attacker could potentially have flash-player execute arbitrary code via specially crafted files.
(CVE-2007-4324, CVE-2007-4768, CVE-2007-5275, CVE-2007-6242, CVE-2007-6243, CVE-2007-6244, CVE-2007-6245, CVE-2007-6246)

Note: Since Adobe doesn't support browsers other than Firefox and Mozilla, this update doesn't work with browsers such as Konqueror.
Updates for konquerors are already in the works.


Update the affected flash-player package.

Plugin Details

Severity: High

ID: 29784

File Name: suse_flash-player-4855.nasl

Version: $Revision: 1.14 $

Type: local

Agent: unix

Published: 2007/12/24

Modified: 2016/12/22

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:flash-player, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/12/04

Reference Information

CVE: CVE-2007-4324, CVE-2007-4768, CVE-2007-5275, CVE-2007-6242, CVE-2007-6243, CVE-2007-6244, CVE-2007-6245, CVE-2007-6246

CWE: 20, 79, 119, 264