openSUSE 10 Security Update : MozillaThunderbird (MozillaThunderbird-4811)

Medium Nessus Plugin ID 29694


The remote openSUSE host is missing a security update.


This update brings Mozilla Thunderbird to security update version

Following security problems were fixed :

- MFSA 2007-29: Crashes with evidence of memory corruption As part of the Firefox update releases Mozilla developers fixed many bugs to improve the stability of the product. Some of these crashes showed evidence of memory corruption under certain circumstances and we presume that with enough effort at least some of these could be exploited to run arbitrary code.

- CVE-2007-5339 Browser crashes

- CVE-2007-5340 JavaScript engine crashes

Also enigmail was upgraded to 0.95.5.


Update the affected MozillaThunderbird packages.

Plugin Details

Severity: Medium

ID: 29694

File Name: suse_MozillaThunderbird-4811.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2007/12/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:MozillaThunderbird, p-cpe:/a:novell:opensuse:MozillaThunderbird-translations, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/12/12

Reference Information

CVE: CVE-2007-5339, CVE-2007-5340

CWE: 20