SuSE 10 Security Update : Mozilla Firefox (ZYPP Patch Number 2423)

High Nessus Plugin ID 29358

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 5.8

Synopsis

The remote SuSE 10 host is missing a security-related patch.

Description

This update brings MozillaFirefox to the security update release 1.5.0.9, including the following security fixes.

http://www.mozilla.org/projects/security/known-vulnerabilities.html

- Crashes with evidence of memory corruption were fixed in the layout engine. CVE-2006-6498 / MFSA 2006-68: Crashes with evidence of memory corruption were fixed in the JavaScript engine. CVE-2006-6499 / MFSA 2006-68: Crashes regarding floating point usage were fixed. CVE-2006-6500 / MFSA 2006-69: This issue only affects Windows systems, Linux is not affected. CVE-2006-6501 / MFSA 2006-70: A privilege escalation using a watch point was fixed.
CVE-2006-6502 / MFSA 2006-71: A LiveConnect crash finalizing JS objects was fixed. CVE-2006-6503 / MFSA 2006-72: A XSS problem caused by setting img.src to javascript: URI was fixed. CVE-2006-6504 / MFSA 2006-73:
A Mozilla SVG Processing Remote Code Execution was fixed. CVE-2006-6505 / MFSA 2006-74: Some Mail header processing heap overflows were fixed. CVE-2006-6506 / MFSA 2006-75: The RSS Feed-preview referrer leak was fixed. CVE-2006-6507 / MFSA 2006-76: A XSS problem using outer window's Function object was fixed. (CVE-2006-6497 / MFSA 2006-68)

Solution

Apply ZYPP patch number 2423.

See Also

http://support.novell.com/security/cve/CVE-2006-6497.html

http://support.novell.com/security/cve/CVE-2006-6498.html

http://support.novell.com/security/cve/CVE-2006-6499.html

http://support.novell.com/security/cve/CVE-2006-6500.html

http://support.novell.com/security/cve/CVE-2006-6501.html

http://support.novell.com/security/cve/CVE-2006-6502.html

http://support.novell.com/security/cve/CVE-2006-6503.html

http://support.novell.com/security/cve/CVE-2006-6504.html

http://support.novell.com/security/cve/CVE-2006-6505.html

http://support.novell.com/security/cve/CVE-2006-6506.html

http://support.novell.com/security/cve/CVE-2006-6507.html

Plugin Details

Severity: High

ID: 29358

File Name: suse_MozillaFirefox-2423.nasl

Version: 1.14

Type: local

Agent: unix

Published: 2007/12/13

Updated: 2019/10/25

Dependencies: 12634

Risk Information

Risk Factor: High

VPR Score: 5.8

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2006/12/20

Reference Information

CVE: CVE-2006-6497, CVE-2006-6498, CVE-2006-6499, CVE-2006-6500, CVE-2006-6501, CVE-2006-6502, CVE-2006-6503, CVE-2006-6504, CVE-2006-6505, CVE-2006-6506, CVE-2006-6507

CWE: 94