openSUSE 10 Security Update : libnetpbm (libnetpbm-4694)

Medium Nessus Plugin ID 29344


The remote openSUSE host is missing a security update.


This update of netpbm fixes a security vulnerability in the included libjasper. This bug can be triggered while processing image files and can lead to remote code execution. (CVE-2007-2721)


Update the affected libnetpbm packages.

Plugin Details

Severity: Medium

ID: 29344

File Name: suse_libnetpbm-4694.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2007/12/12

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libnetpbm, p-cpe:/a:novell:opensuse:libnetpbm-32bit, p-cpe:/a:novell:opensuse:libnetpbm-devel, p-cpe:/a:novell:opensuse:libnetpbm10, p-cpe:/a:novell:opensuse:libnetpbm10-32bit, p-cpe:/a:novell:opensuse:netpbm, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/11/13

Reference Information

CVE: CVE-2007-2721