FreeBSD : Squid -- Denial of Service Vulnerability (6eb580d7-a29c-11dc-8919-001c2514716c)

Medium Nessus Plugin ID 29230


The remote FreeBSD host is missing one or more security-related updates.


Squid secuirty advisory reports :

Due to incorrect bounds checking Squid is vulnerable to a denial of service check during some cache update reply processing.

This problem allows any client trusted to use the service to perform a denial of service attack on the Squid service.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 29230

File Name: freebsd_pkg_6eb580d7a29c11dc8919001c2514716c.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2007/12/07

Modified: 2015/05/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:squid, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2007/12/04

Vulnerability Publication Date: 2007/11/28

Reference Information

CVE: CVE-2007-6239

BID: 26687

CWE: 20