openSUSE 10 Security Update : rubygem-actionpack (rubygem-actionpack-4754)

Medium Nessus Plugin ID 28371


The remote openSUSE host is missing a security update.


Malicious users could specify their session-ID in the URL and could gain access to an authenticated session that way (CVE-2007-5380).


Update the affected rubygem-actionpack package.

Plugin Details

Severity: Medium

ID: 28371

File Name: suse_rubygem-actionpack-4754.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2007/11/30

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:rubygem-actionpack, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/11/27

Reference Information

CVE: CVE-2007-5380