openSUSE 10 Security Update : nagios-plugins (nagios-plugins-4621)

Medium Nessus Plugin ID 28356


The remote openSUSE host is missing a security update.


fix possible buffer overflow during HTTP Location header parsing in check_http (CVE-2007-5198) fix possible buffer overflow during snmpget parsing in check_snmp (CVE-2007-5623)


Update the affected nagios-plugins packages.

Plugin Details

Severity: Medium

ID: 28356

File Name: suse_nagios-plugins-4621.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/11/29

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:nagios-plugins, p-cpe:/a:novell:opensuse:nagios-plugins-extras, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/11/06

Reference Information

CVE: CVE-2007-5198, CVE-2007-5623

CWE: 119