openSUSE 10 Security Update : emacs (emacs-4732)

High Nessus Plugin ID 28355


The remote openSUSE host is missing a security update.


This update fixes a buffer overflow in emacs that can be triggered over the command-line.


Update the affected emacs packages.

Plugin Details

Severity: High

ID: 28355

File Name: suse_emacs-4732.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2007/11/29

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:emacs, p-cpe:/a:novell:opensuse:emacs-el, p-cpe:/a:novell:opensuse:emacs-info, p-cpe:/a:novell:opensuse:emacs-nox, p-cpe:/a:novell:opensuse:emacs-x11, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/11/24