FreeBSD : rubygem-rails -- JSON XSS vulnerability (44fb0302-9d38-11dc-9114-001c2514716c)

Medium Nessus Plugin ID 28350


The remote FreeBSD host is missing one or more security-related updates.


Rails core team reports :

All users of Rails 1.2.4 or earlier are advised to upgrade to 1.2.5, though it isn't strictly necessary if you aren't working with JSON.
For more information the JSON vulnerability, see CVE-2007-3227.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 28350

File Name: freebsd_pkg_44fb03029d3811dc9114001c2514716c.nasl

Version: $Revision: 1.9 $

Type: local

Published: 2007/11/29

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:rubygem-activesupport, p-cpe:/a:freebsd:freebsd:rubygem-rails, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2007/11/28

Vulnerability Publication Date: 2007/10/12

Reference Information

CVE: CVE-2007-3227

CWE: 79