openSUSE 10 Security Update : perl (perl-4675)

High Nessus Plugin ID 28286


The remote openSUSE host is missing a security update.


This update fixes a buffer overflow in perl's regex engine.


Update the affected perl packages.

Plugin Details

Severity: High

ID: 28286

File Name: suse_perl-4675.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/11/20

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:perl, p-cpe:/a:novell:opensuse:perl-32bit, p-cpe:/a:novell:opensuse:perl-base, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/11/08

Reference Information

CVE: CVE-2007-5116

CWE: 119