FreeBSD : php -- multiple security vulnerabilities (392b5b1d-9471-11dc-9db7-001c2514716c)

Medium Nessus Plugin ID 28259


The remote FreeBSD host is missing a security-related update.


PHP project reports :

Security Enhancements and Fixes in PHP 5.2.5 :

- Fixed dl() to only accept filenames. Reported by Laurent Gaffie.

- Fixed dl() to limit argument size to MAXPATHLEN (CVE-2007-4887).
Reported by Laurent Gaffie.

- Fixed htmlentities/htmlspecialchars not to accept partial multibyte sequences. Reported by Rasmus Lerdorf

- Fixed possible triggering of buffer overflows inside glibc implementations of the fnmatch(), setlocale() and glob() functions.
Reported by Laurent Gaffie.

- Fixed 'mail.force_extra_parameters' php.ini directive not to be modifiable in .htaccess due to the security implications. Reported by SecurityReason.

- Fixed bug #42869 (automatic session id insertion adds sessions id to non-local forms).

- Fixed bug #41561 (Values set with php_admin_* in httpd.conf can be overwritten with ini_set()).


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 28259

File Name: freebsd_pkg_392b5b1d947111dc9db7001c2514716c.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2007/11/20

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:php5, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/11/16

Vulnerability Publication Date: 2007/11/08

Reference Information

CVE: CVE-2007-4887

BID: 26403

CWE: 20