openSUSE 10 Security Update : xen (xen-4616)

Medium Nessus Plugin ID 28207


The remote openSUSE host is missing a security update.


This update merges back the Xen version from SLES 10 Service Pack 1 to the 10.1 codebase, which should make it work again.

Nevertheless we recommend Xen users to use the latest openSUSE release (10.3) for Xen usage.

Additionaly a /tmp race was fixed (CVE-2007-3919).


Update the affected xen packages.

Plugin Details

Severity: Medium

ID: 28207

File Name: suse_xen-4616.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2007/11/14

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6

Vector: CVSS2#AV:L/AC:M/Au:S/C:N/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:xen, p-cpe:/a:novell:opensuse:xen-devel, p-cpe:/a:novell:opensuse:xen-doc-html, p-cpe:/a:novell:opensuse:xen-doc-pdf, p-cpe:/a:novell:opensuse:xen-doc-ps, p-cpe:/a:novell:opensuse:xen-libs, p-cpe:/a:novell:opensuse:xen-libs-32bit, p-cpe:/a:novell:opensuse:xen-tools, p-cpe:/a:novell:opensuse:xen-tools-ioemu, cpe:/o:novell:opensuse:10.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/10/29

Reference Information

CVE: CVE-2007-3919

CWE: 59