FreeBSD : mt-daapd -- denial of service vulnerability (a7080c30-91a2-11dc-b2eb-00b0d07e6c7e)

High Nessus Plugin ID 28195


The remote FreeBSD host is missing a security-related update.


US-CERT reports :

webserver.c in mt-dappd in Firefly Media Server 0.2.4 and earlier allows remote attackers to cause a denial of service (NULL dereference and daemon crash) via a stats method action to /xml-rpc with (1) an empty Authorization header line, which triggers a crash in the ws_decodepassword function; or (2) a header line without a ':' character, which triggers a crash in the ws_getheaders function.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 28195

File Name: freebsd_pkg_a7080c3091a211dcb2eb00b0d07e6c7e.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2007/11/14

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:mt-daapd, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2007/11/12

Vulnerability Publication Date: 2007/11/05

Reference Information

CVE: CVE-2007-5824

CWE: 20