openSUSE 10 Security Update : xpdf (xpdf-4643)

High Nessus Plugin ID 28179

Synopsis

The remote openSUSE host is missing a security update.

Description

A buffer overflow in xpdf could be exploited by attackers to potentially execute arbitrary code (CVE-2007-4352, CVE-2007-5392, CVE-2007-5393).

Solution

Update the affected xpdf packages.

Plugin Details

Severity: High

ID: 28179

File Name: suse_xpdf-4643.nasl

Version: Revision: 1.8

Type: local

Agent: unix

Published: 2007/11/12

Updated: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:xpdf, p-cpe:/a:novell:opensuse:xpdf-tools, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/11/07

Reference Information

CVE: CVE-2007-4352, CVE-2007-5392, CVE-2007-5393

CWE: 119