openSUSE 10 Security Update : liblcms (liblcms-4629)

High Nessus Plugin ID 28175


The remote openSUSE host is missing a security update.


This update addresses security bugs in liblcms that occurred while parsing ICC profiles in JPEG images. (CVE-2007-2741) Remote attackers can exploit this bug to execute arbitrary commands or cause denial-of-service.


Update the affected liblcms packages.

Plugin Details

Severity: High

ID: 28175

File Name: suse_liblcms-4629.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2007/11/12

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:liblcms, p-cpe:/a:novell:opensuse:liblcms-32bit, p-cpe:/a:novell:opensuse:liblcms-devel, p-cpe:/a:novell:opensuse:liblcms-devel-32bit, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/11/06

Reference Information

CVE: CVE-2007-2741

CWE: 119