openSUSE 10 Security Update : libextractor (libextractor-4646)

High Nessus Plugin ID 28174


The remote openSUSE host is missing a security update.


A buffer overflow in the xpdf code contained in libextractor could be exploited by attackers to potentially execute arbitrary code (CVE-2007-4352, CVE-2007-5392, CVE-2007-5393).


Update the affected libextractor packages.

Plugin Details

Severity: High

ID: 28174

File Name: suse_libextractor-4646.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/11/12

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libextractor, p-cpe:/a:novell:opensuse:libextractor-devel, cpe:/o:novell:opensuse:10.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/11/08

Reference Information

CVE: CVE-2007-4352, CVE-2007-5392, CVE-2007-5393

CWE: 119