openSUSE 10 Security Update : emacs (emacs-4620)

Medium Nessus Plugin ID 27647


The remote openSUSE host is missing a security update.


The setting ':safe' of 'enable-local-variables' could be bypassed by specially crafted files (CVE-2007-5795).


Update the affected emacs packages.

Plugin Details

Severity: Medium

ID: 27647

File Name: suse_emacs-4620.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2007/11/06

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.3

Vector: CVSS2#AV:L/AC:M/Au:N/C:N/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:emacs, p-cpe:/a:novell:opensuse:emacs-el, p-cpe:/a:novell:opensuse:emacs-info, p-cpe:/a:novell:opensuse:emacs-nox, p-cpe:/a:novell:opensuse:emacs-x11, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/11/06

Reference Information

CVE: CVE-2007-5795