FreeBSD : gftp -- multiple vulnerabilities (f8b0f83c-8bb3-11dc-bffa-0016179b2dd5)

High Nessus Plugin ID 27641


The remote FreeBSD host is missing a security-related update.


Gentoo reports :

Kalle Olavi Niemitalo discovered two boundary errors in fsplib code included in gFTP when processing overly long directory or file names.

A remote attacker could trigger these vulnerabilities by enticing a user to download a file with a specially crafted directory or file name, possibly resulting in the execution of arbitrary code or a Denial of Service.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 27641

File Name: freebsd_pkg_f8b0f83c8bb311dcbffa0016179b2dd5.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2007/11/06

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:gftp, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2007/11/05

Vulnerability Publication Date: 2007/11/01

Reference Information

CVE: CVE-2007-3961, CVE-2007-3962

CWE: 119