openSUSE 10 Security Update : libvorbis (libvorbis-4583)

Medium Nessus Plugin ID 27606


The remote openSUSE host is missing a security update.


Specially crafted OGG files could crash libvorbis or make it run into an endless loop (CVE-2007-4029, CVE-2007-4065, CVE-2007-4066).


Update the affected libvorbis packages.

Plugin Details

Severity: Medium

ID: 27606

File Name: suse_libvorbis-4583.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/11/01

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libvorbis, p-cpe:/a:novell:opensuse:libvorbis-32bit, p-cpe:/a:novell:opensuse:libvorbis-devel, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/10/22

Reference Information

CVE: CVE-2007-4029, CVE-2007-4065, CVE-2007-4066

CWE: 119