openSUSE 10 Security Update : ImageMagick (ImageMagick-4543)

High Nessus Plugin ID 27604


The remote openSUSE host is missing a security update.


This update of ImageMagick fixes several vulnerabilities.

- CVE-2007-4985: infinite loop while parsing images

- CVE-2007-4986: integer overflows that can lead to code execution

- CVE-2007-4987: one-byte buffer overflow that can lead to code execution (SLES8- and SLES9-based products are not affected)

- CVE-2007-4988: integer overflows that can lead to code execution


Update the affected ImageMagick packages.

Plugin Details

Severity: High

ID: 27604

File Name: suse_ImageMagick-4543.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/11/01

Modified: 2016/12/22

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:ImageMagick, p-cpe:/a:novell:opensuse:ImageMagick-Magick++, p-cpe:/a:novell:opensuse:ImageMagick-Magick++-devel, p-cpe:/a:novell:opensuse:ImageMagick-devel, p-cpe:/a:novell:opensuse:perl-PerlMagick, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/10/12

Reference Information

CVE: CVE-2007-4985, CVE-2007-4986, CVE-2007-4987, CVE-2007-4988

CWE: 119, 189, 399