openSUSE 10 Security Update : flac (flac-4571)

High Nessus Plugin ID 27530


The remote openSUSE host is missing a security update.


Multiple integer overflows in flac could potentially be exploited by attackers via specially crafted files to execute code in the context of the user opening the file (CVE-2007-4619).


Update the affected flac packages.

Plugin Details

Severity: High

ID: 27530

File Name: suse_flac-4571.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2007/10/24

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:flac, p-cpe:/a:novell:opensuse:flac-32bit, p-cpe:/a:novell:opensuse:flac-devel, p-cpe:/a:novell:opensuse:libFLAC++6, p-cpe:/a:novell:opensuse:libFLAC++6-32bit, p-cpe:/a:novell:opensuse:libFLAC8, p-cpe:/a:novell:opensuse:libFLAC8-32bit, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/10/19

Reference Information

CVE: CVE-2007-4619

CWE: 189