openSUSE 10 Security Update : NX (NX-4555)

High Nessus Plugin ID 27510


The remote openSUSE host is missing a security update.


The XFree code contained in NX was prone to integer overflows (CVE-2006-1861) and insufficiently protected against specially crafted PCF files (CVE-2006-3467).


Update the affected NX package.

Plugin Details

Severity: High

ID: 27510

File Name: suse_NX-4555.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/10/18

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:NX, cpe:/o:novell:opensuse:10.1, cpe:/o:novell:opensuse:10.2, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/10/17

Reference Information

CVE: CVE-2006-1861, CVE-2006-3467