openSUSE 10 Security Update : zypper (zypper-4443)

High Nessus Plugin ID 27505


The remote openSUSE host is missing a security update.


This update of zypper fixes some security related bugs that occur while handling files. These bugs can be abused to get access to log-files for reading and writing as well as causing denial-of-service conditions. Thanks to Stefan Nordhausen for reporting this.


Update the affected zypper package.

Plugin Details

Severity: High

ID: 27505

File Name: suse_zypper-4443.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:zypper, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/09/26