openSUSE 10 Security Update : xsupplicant (xsupplicant-2459)

High Nessus Plugin ID 27502


The remote openSUSE host is missing a security update.


xsupplicant has been upgraded to version 1.2.8, which includes bugfixes and one security fix :

CVE-2006-5601: A post-authentication stack overflow in the EAP handling could be used by already authenticated attacker to overflow a stackbuffer and so potentially execute code.


Update the affected xsupplicant package.

Plugin Details

Severity: High

ID: 27502

File Name: suse_xsupplicant-2459.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:xsupplicant, cpe:/o:novell:opensuse:10.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/01/12

Reference Information

CVE: CVE-2006-5601