openSUSE 10 Security Update : wv2 (wv2-1687)

Medium Nessus Plugin ID 27480


The remote openSUSE host is missing a security update.


The wv2 library was updated to fix some boundary checks which could be exploited by maliciously crafted files to access memory outside bounds and possibly execute arbitrary code. (CVE-2006-2197)


Update the affected wv2 packages.

Plugin Details

Severity: Medium

ID: 27480

File Name: suse_wv2-1687.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:wv2, p-cpe:/a:novell:opensuse:wv2-devel, cpe:/o:novell:opensuse:10.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2006/06/28

Reference Information

CVE: CVE-2006-2197