openSUSE 10 Security Update : wireshark (wireshark-2638)

Medium Nessus Plugin ID 27477


The remote openSUSE host is missing a security update.


Wireshark 0.99.5 fixes four vulnerabilities :

- CVE-2007-0459 The TCP dissector could hang or crash

- CVE-2007-0458 The HTTP dissector could crash

- CVE-2007-0457 The IEEE 802.11 dissector could crash

- CVE-2007-0456 The LLT dissector could crash


Update the affected wireshark packages.

Plugin Details

Severity: Medium

ID: 27477

File Name: suse_wireshark-2638.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2007/10/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:wireshark, p-cpe:/a:novell:opensuse:wireshark-devel, cpe:/o:novell:opensuse:10.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2007/02/26

Reference Information

CVE: CVE-2007-0456, CVE-2007-0457, CVE-2007-0458, CVE-2007-0459